Всем привет, здесь мы учимся программировать на Java, сегодня новый урок под номером семь. Начнем!
Что такое цикл? Это что-то повторяющееся, выполняющееся идентично из раза в раз. Одним из видов циклов является цикл while. Выглядит он следующим образом:
while(условие){
тело цикла
}
Тело цикла будет выполняться до тех пор, пока условие цикла не станет ложно. Давайте попробуем написать программу обратного отсчета запуска ракеты!
1 2 3 4 5 6 7 8 9 10 11 12 |
public class Main { public static void main(String[] args) { int countDown = 5; while(countDown >= 0){ System.out.println("Через "+countDown+"..."); countDown--; } System.out.print("Старт!"); } } |
Результатом будет следующее:
1 2 3 4 5 6 7 |
Через 5... Через 4... Через 3... Через 2... Через 1... Через 0... Старт! |
Иногда ваша программа может «сломаться», если цикл окажется бесконечным. Допустим, как здесь:
1 2 3 4 5 6 7 8 9 10 11 |
public class Main { public static void main(String[] args) { int a = 10; while(a > 9){ System.out.println("a = " + a); a++; } } } |
Так как переменная a возрастает, то условие цикла всегда будет верно, и программе придется «вмешаться» и прекратить работать. Если же условие неверно изначально, то цикл не выполнится ни разу. Однако есть интересная вариация данного цикла, которая выполниться как минимум один раз, и называется она do-while:
do{
тело цикла
}while(условие);
Сначала выполнится тело цикла, а уже потом проверится условие. Если верно, то тело цикла выполнится еще раз; если же условие неверно, то по итогу цикл выполнится лишь однажды. Тот же пример с ракетой, только используя do-while:
1 2 3 4 5 6 7 8 9 10 11 12 13 |
public class Main { public static void main(String[] args) { int countDown = 5; do{ System.out.println("Через "+countDown+"..."); countDown--; }while(countDown >= 0); System.out.print("Старт!"); } } // Выведет то же самое, что и первый пример |
Пока что этого хватит. На следующем уроке изучим некоторые интересные «фишки», а также другой вид цикла. Удачи!
Переходите на следующий урок: